reparando twitter tools

tras el cambio de alojamiento de dreamhost a ovh que he hecho estos días de principios de año (gracias por el consejo @goldrak) aparentemente todo funcionaba con normalidad, pero como no podía ser de otro modo, siempre hay algo que tiene que fallar….

venía usando el plugin de wordpress twitter tools para conectar automáticamente mi cuenta de twitter con el blog, pero tras el traslado me di cuenta de que el plugin había dejado de funcionar y arrojaba un bonito error:

Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /wp-content/plugins/twitter-tools/twitteroauth.php on line 19

parece ser que la cosa es que este plugin necesita PHP5 para funcionar y yo volviendome loco ya que mi nuevo hosting en teoría soporta PHP4 y PHP5

la solución ?

pues aparentemente, tan sencilla como incluir en el .htaccess la línea

SetEnv PHP_VER 5

para forzar el procesamiento en esa versión y no en la 4….

en principio en plugin ya conecta con twitter, y ahora en cuanto le de a «publicar» veremos si es cierto…..

3 comentarios sobre “reparando twitter tools”

  1. Bien de bien!!! Espero que te guste el nuevo sitio, creo que lo del PHP es configurable desde el panel de control.

  2. la verdad es que es muchísimo más simple que dreamhost y se pueden hacer menos cosas, pero también es muchísimo más económico y da para hacer todo lo que necesites sin problemas….

    además al estar aquí al lado es mucho más rápido de lo que era dreamhost desde eeuu

    lo cierto es que estoy muy contento con el cambio, gracias por el consejo!!

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.